[Mikrotik] Version 6.1 Script vs 5.xx

Grand Avenue Broadband grandavebb at grandavebb.com
Tue Jul 2 19:54:48 CDT 2013


Don't try to use scripts or scheduling.

Put the contents of the script in a file called something.rsc.  Log in to the router terminal mode and issue

   import something.rsc

Then you will get echoes of the lines in the file along with the error message in the right spot, and should be able to tell which one is failing.

On Jul 2, 2013, at 2:36 PM, "Jerry Allen" <jerryallen.mt at vistabeam.com> wrote:

> Thanks for the suggestions,
> 
> I tried adding the semicolons, it appears there is no change. The below
> script is ran via the scheduler at 60 second intervals. The blocks.rsc and
> unblocks.rsc are uploaded to the router(s) using ftp.
> * Where does the output of the script executed from the schedule as well as
> the subsequent block.rsc or unblock.rsc get sent?
> * Is there a way of logging the results of the entire script or debugging
> the script(s) and scheduler?
> 
> It would be great if the output was logged in some way. I tried logging
> debug, no script output to the log, I tried logging script no script output
> to the log.
> 
> Jerry
> 
> 
> -----Original Message-----
> From: mikrotik-bounces at mail.butchevans.com
> [mailto:mikrotik-bounces at mail.butchevans.com] On Behalf Of Grand Avenue
> Broadband
> Sent: Friday, June 28, 2013 7:48 PM
> To: Mikrotik discussions
> Subject: Re: [Mikrotik] Version 6.1 Script vs 5.xx
> 
> Semicolons are suitable at the end of every line except 1 and 7.  See if
> that changes the behavior.
> 
> Note also that in v6, import actually echoes the lines it is executing.
> That may help you debug this.
> 
> On Jun 28, 2013, at 4:01 PM, "Jerry Allen" <jerryallen.mt at vistabeam.com>
> wrote:
> 
>> I hate Outlook at times :)
>> Thanks for the response.
>> Line numbered script, 12 lines, every line begins with a number - no
> errant slashes, there are no line breaks in places that break the syntax, I
> have 200+ v 5.x devices that this works on, V6 it does not.
>> Can someone help me with where the semicolons need to be below? Of course
> the line numbers will be removed, this is to assist since some place it is
> getting wrapped/munged I guess
>> 
>> 1 - :if ([:len [/file find name=blocks.rsc]] > 0) do={
>> 2 - /import blocks.rsc
>> 3 - :delay 10
>> 4 - /file remove blocks.rsc
>> 5 - }
>> 6
>> 7 - :if ([:len [/file find name=unblocks.rsc]] > 0) do={
>> 8 - /import unblocks.rsc
>> 9 - :delay 10
>> 10 - /file remove unblocks.rsc
>> 11 - }
>> 12 - /ip firewall address-list print without-paging file=list.rsc
>> 
>> Thanks again,
>> 
>> Jerry
>> 
>> -----Original Message-----
>> From: mikrotik-bounces at mail.butchevans.com
> [mailto:mikrotik-bounces at mail.butchevans.com] On Behalf Of Grand Avenue
> Broadband
>> Sent: Friday, June 28, 2013 2:40 PM
>> To: Mikrotik discussions
>> Subject: Re: [Mikrotik] Version 6.1 Script vs 5.xx
>> 
>> I'm assuming the second do with the bracket, slash, and then a newline Is
> a typo on your part. If not, that's your problem. Otherwise, try inserting
> semicolons in all the appropriate places - it never hurts.
>> 
>> On Jun 28, 2013, at 11:12 AM, "Jerry Allen" <jerryallen.mt at vistabeam.com>
> wrote:
>> 
>>> For some reason email does not have the line breaks in the correct spot?
>>> 
>>> Edited for proper display<clip>
>> 
>> _______________________________________________
>> Mikrotik mailing list
>> Mikrotik at mail.butchevans.com
>> http://mail.butchevans.com/mailman/listinfo/mikrotik
>> 
>> Visit http://blog.butchevans.com/ for tutorials related to Mikrotik
> RouterOS
> 
> _______________________________________________
> Mikrotik mailing list
> Mikrotik at mail.butchevans.com
> http://mail.butchevans.com/mailman/listinfo/mikrotik
> 
> Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS
> 
> _______________________________________________
> Mikrotik mailing list
> Mikrotik at mail.butchevans.com
> http://mail.butchevans.com/mailman/listinfo/mikrotik
> 
> Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS



More information about the Mikrotik mailing list