[Mikrotik] IPV6 DHCP6PD configuration

Butch Evans butche at butchevans.com
Wed Jun 6 17:37:47 CDT 2012


On Wed, 2012-06-06 at 19:17 +0300, Meftah Tayeb wrote:
> Hello folks,
> i'm runing RouterOs 5.17 on a RB493G
> this RB493G have a Cisco Linksys E3200 linked it into eth2
> i want to do DHCP6PD on it with a HE.NET tunnel
> the Edge point of my network is a cisco C2851 and the tunnel is working just 
> fine from that point to the rb493g
> so, here's my actual situation
> My /48 prefix is:
> 2001:470:724d::/48
> 
> i want to exclude:
> 
> 2001:470:724d:1::/64,2,3,4, and 5 /64 is reserved for diferent 
> interconnection

Best to just reserve something like a /56 then.  That would be:
2001:470:724d::/56, which is
2001:470:724d:0000:: through 2001:470:424d:00FF::
You would have 256 (8 bits of subnetting) /64 subnets reserved.

Then, you can do a /56 pool like this:

/ipv6 pool 
add name=lan prefix=2001:470:724d:100::/56 prefix=length=64

This pool is 256 subnets, with each being 64 bits long (/64)

Next, you add the server (like you did below):

> /ipv6 dhcp-server
> add address-pool=lan authoritative=after-2sec-delay disabled=yes
> lan2 lease-time=3d name=lan

This is correct.  With the corrected pool as shown above, your devices
that request dhcpv6-pd will obtain a /64 from the pool.  In the
Mikrotik, a route will be automatically generated for each assigned /64
from the pool.

> but all i get is a local link address or a something else on my pc while the 
> E3200 get a 0000000000000000000000000000000000000000000 address on the wan 
> side, biut receyve the /112 prefix from the RB493G
> 
> am i doing something bad here?

Mikrotik (by default) turns on RA for IPs adding in the global routing
range.  No need to change the settings under the RA settings (Mikrotik
calls this neighbor discovery at IPv6->nd).  Some operating systems will
not like smaller than a /64 subnet, so that may be causing part of your
issues.
-- 
********************************************************************
* Butch Evans                * Professional Network Consultation   *
* http://www.butchevans.com/ * Network Engineering                 *
* http://store.wispgear.net/ * Wired or Wireless Networks          *
* http://blog.butchevans.com/ * ImageStream, Mikrotik and MORE!    *
*          NOTE THE NEW PHONE NUMBER: 702-537-0979                 *
********************************************************************





More information about the Mikrotik mailing list